Excel-Formeln zur Lösung einer quadratischen Gleichung

Eingestellt: 23.09.2011
Letzte Änderung: 23.09.2011


 

Quadratische Gleichung (Gleichung 2. Grades)

Die allgemeine Form der quadratischen Gleichung lautet

(#1a)

aus welcher sich äquivalent die Normalform gewinnen lässt,
indem durch a dividiert wird

(#1b)

wobei

(#2)

und

(#3)

ist.

In Abhängigkeit vom Vorzeichen der Diskriminante,
welche bei Vorliegen der allgemeinen Form (#1a) dem Ausdruck

(#4a)

und bei Vorliegen der Normalform (#1b) dem Ausdruck

(#4b)

entspricht[1], ergibt sich:

  • für eine positive Diskriminante gibt es zwei reelle Lösungen (zwei reelle Wurzeln),
  • für eine Diskriminante mit dem Wert null gibt es eine reelle Lösung (zwei zusammenfallende Wurzeln),
  • für eine negative Diskriminante gibt es keine reelle Lösung (zwei komplexe Wurzeln).
  • Die Anwendung von Lösungsformeln[2] zur Lösung der quadratischer Gleichung führt für die allgemeine Form (#1a) nach der sogenannten abc-Formel oder auch Mitternachtsformel auf die Lösungen

    (#5a)

    und für die Normalform (#1b) nach der sogenannten pq-Formel auf die Lösungen

    (#5b)

     

    Excel-Formeln zur Lösung einer quadratischen Gleichung

    Als Ansatz für eine Excel-Formel zur Lösung einer quadratischen Gleichung soll die abc-Formel  (bzw. Mitternachtsformel) aus #5a bei Vorliegen der allgemeinen Form (#1a) bzw. die pq-Formel aus #5b bei Vorliegen der Normalform (#1b) herangezogen werden. Darüber hinaus soll ein und die selbe Excel-Formel beide Lösungen liefern, wobei der Fehlerwert #ZAHL! ausgegeben werden soll, wenn keine reelle Lösung vorliegt.

    - Allgemeine Form

    Werden für die verwendeten Zellen Namen entsprechend ihres Gliedes definiert, so lassen sich unter Berücksichtigung des Vorzeichens der Diskriminante für die abc-Formel  (bzw. Mitternachtsformel) aus #5a folgende Excel-Formeln schreiben für x1:[3]

    =WENN(b^2-4*a*c<0;#ZAHL!;
    WENN(b^2-4*a*c=0;-b/(2*a);(-b+(b^2-4*a*c)^0,5)/(2*a)))

    und für x2:

    =WENN(b^2-4*a*c<=0;#ZAHL!;
    (-b-(b^2-4*a*c)^0,5)/(2*a))

    Bei der Entwicklung einer Arrayformel, die die Lösungen sowohl für x1 als auch x2 bereitstellen soll, wird im ersten Schritt die abc-Formel ohne Fallunterscheidung für x1

    =(-b+(b^2-4*a*c)^0,5)/(2*a)

    und für x2

    =(-b-(b^2-4*a*c)^0,5)/(2*a)

    betrachtet. Um abzulesen wie die Lösungsmenge der quadratischen Gleichung beschaffen ist, kann die Excel-Funktion VORZEICHEN verwendet werden, die den Wert der Diskriminante aus #4a untersucht:

    =VORZEICHEN(b^2-4*a*c)

    Die Excel-Funktion VORZEICHEN(Zahl) liefert:

  • den Wert 1, wenn Zahl positiv ist,
  • den Wert 0, wenn Zahl null ist,
  • den Wert -1, wenn Zahl negativ ist.
  • Damit entsprechend der Lösungsmenge der richtige Faktor für die Wurzel der Diskriminante gewählt wird, wird dieser die Excel-Funktion WAHL vorgeschaltet. Für x1 soll der Faktor 1 (bzw. 0, #ZAHL!) lauten, wenn die Diskriminante positiv (bzw. null, negativ) ist:

    =WAHL(2-VORZEICHEN(b^2-4*a*c);1;0;#ZAHL!)

    Für x2 soll der Faktor -1 (bzw. #ZAHL!, #ZAHL!) lauten, wenn die Diskriminante positiv (bzw. null, negativ) ist:

    =WAHL(2-VORZEICHEN(b^2-4*a*c);-1;#ZAHL!;#ZAHL!)

    Auf den ersten Blick lassen sich die beiden vorstehenden Excel-Formeln nicht vereinheitlichen. Unter Beachtung, dass für x1 auch

    =WAHL(2-VORZEICHEN(b^2-4*a*c);1;-1;#ZAHL!)

    zulässig ist und dass eine Arrayformel aufgestellt werden soll, lässt sich jedoch folgende Excel-Formel für die Faktoren von x1 and x2 finden:

    {=WAHL(ZEILE(2:3)-VORZEICHEN(b^2-4*a*c);
    1;-1;#ZAHL!;#ZAHL!)}
    Diese in die abc-Formel ohne Fallunterscheidung eingesetzt ergibt eine Excel-Formel zur Lösung einer quadratischen Gleichung bei Vorliegen der allgemeinen Form:
    {=(-b+(WAHL(ZEILE(2:3)-VORZEICHEN(b^2-4*a*c);
    1;-1;#ZAHL!;#ZAHL!))*(b^2-4*a*c)^0,5)/(2*a)}

    Sie ist eine Arrayformel und liefert als Ergebnis einen Zeilenvektor mit zwei Zeilen.

    -Normalform:

    Die vorstehenden Überlegungen lassen sich für eine Excel-Formel zur Lösung einer quadratischen Gleichung bei Vorliegen der Normalform (#1b) übertragen.

    Die Excel-Formeln für die pq-Formel nach #5b können demnach lauten für x1:

    =WENN(p^2-4*q<0;#ZAHL!;
    WENN(p^2-4*q=0;-p/2;-p/2+((p/2)^2-q)^0,5))

    und für x2:

    =WENN(p^2-4*q<=0;#ZAHL!;-p/2-((p/2)^2-q)^0,5)

    Eine entsprechende Arrayformel ergibt sich aus:

    {=(-p+(WAHL(ZEILE(2:3)-VORZEICHEN(p^2-4*q);
    1;-1;#ZAHL!;#ZAHL!))*(p^2-4*q)^0,5)/2}

     

    Benutzerdefinierte Funktion zur Lösung einer quadratischen Gleichung

    Auch bei der nachstehenden benutzerdefinierten Funktion QuadEq(a,b,c) zur Lösung einer quadratischen Gleichung wird eine Fallunterscheidung anhand des Vorzeichens der Diskriminante vorgenommen.

    Zusätzlich stellt die Funktion QuadEq(a,b,c) wahlweise die Lösungen für die allgemeine Form und für die Normalform bereit.

    Function QuadEq(ByVal a As Double, _
                    ByVal b As Double, _
           Optional ByVal c As Variant) As Variant
    
        Dim p                           As Double
        Dim q                           As Double
        Dim d                           As Double
        Dim arr(0 To 1, 0 To 0)         As Variant
            
        If IsMissing(c) Then
            p = a
            q = b
        Else
            If a = 0 Then
                arr(0, 0) = CVErr(xlErrDiv0)
                arr(1, 0) = CVErr(xlErrDiv0)
                QuadEq = arr
                Exit Function
            Else
                p = b / a
                q = c / a
            End If
        End If
        
        d = p ^ 2 - 4 * q
            
        Select Case d
            Case Is > 0
                arr(0, 0) = (-p + Sqr(d)) / 2
                arr(1, 0) = (-p - Sqr(d)) / 2
            Case 0
                arr(0, 0) = -p / 2
                arr(1, 0) = CVErr(xlErrNum)
            Case Is < 0
                arr(0, 0) = CVErr(xlErrNum)
                arr(1, 0) = CVErr(xlErrNum)
        End Select
        
        QuadEq = arr
    
    End Function

     

    Beispiel

    In folgender Abbildung 1 finden Sie drei Beispiele (Diskriminante positiv, null, negativ) zur Lösung einer quadratischen Gleichung bei Vorliegen der allgemeinen Form als auch bei Vorliegen der Normalform mit den vorgestellten Excel-Formeln sowie der benutzerdefinierten Funktion QuadEq(a,b,c).


    Formeln in der Tabelle:
    -Allgemeine Form · abc-Formel:
    C7: =C5^2-4*B5*D5
    und
    C9: =WENN(C5^2-4*B5*D5<0;#ZAHL!;
    WENN(C5^2-4*B5*D5=0;-C5/(2*B5);(-C5+(C5^2-4*B5*D5)^0,5)/(2*B5)))
    C10: =WENN(C5^2-4*B5*D5<=0;#ZAHL!;(-C5-(C5^2-4*B5*D5)^0,5)/(2*B5))
    bzw.
    C9:C10: {=(-C5+(WAHL(ZEILE(2:3)-VORZEICHEN(C5^2-4*B5*D5);
    1;-1;#ZAHL!;#ZAHL!))*(C5^2-4*B5*D5)^0,5)/(2*B5)}
    bzw.
    C9:C10: {=QuadEq(B5;C5;D5)}
    -Normalform · pq-Formel:
    C17: =B15^2-4*C15
    und
    C19: =WENN(B15^2-4*C15<0;#ZAHL!;
    WENN(B15^2-4*C15=0;-B15/2;-B15/2+((B15/2)^2-C15)^0,5))
    C20: =WENN(B15^2-4*C15<=0;#ZAHL!;-B15/2-((B15/2)^2-C15)^0,5)
    bzw.
    C19:C20: {=(-B15+(WAHL(ZEILE(2:3)-VORZEICHEN(B15^2-4*C15);
    1;-1;#ZAHL!;#ZAHL!))*(B15^2-4*C15)^0,5)/2
    bzw.
    C19:C20: {=QuadEq(B15;C15)}

    Abbildung 1: Excel-Formeln zur Lösung quadratischer Gleichungen.

     

    [1] Bitte beachten Sie, dass sich in der Literatur auch davon abweichende Definitionen der Diskriminante finden.

    [2] Neben Lösungsformeln gibt es als weitere Methode zur Lösung der quadratischen Gleichung die Faktorenzerlegung (bzw. den Satz von Vieta), auf die an dieser Stelle jedoch nicht weiter eingegangen wird.

    [3] Bitte beachten Sie, dass ab Excel 2007 der Name c nicht mehr zulässig ist. Wählen Sie in diesem Fall anstelle von c einen anderen, gültigen Namen bspw. c_.

     

    Haben Sie Fragen oder Anregungen zu diesem Artikel?

    Dann senden Sie einfach eine Nachricht an:

    E-Mail:

     

    Lesen Sie auch:
    ___________________________________________________________________

    Excel-Formeln für die Binomische Formeln