Excel 2010: Bug in den Excel-Funktionen SUMMEWENN(S) und MITTELWERTWENN(S)

Eingestellt: 13.09.2010
Letzte Änderung: 29.06.2011


 

Aktuelles (Stand: 29.06.2011)

Der in diesem Artikel beschriebene Bug in Excel 2010 soll 
laut Microsoft Hilfe und Support in

Article ID: 2345345 -
Last Review: September 9, 2010 -
Revision: 2.0

Description of the Excel 2010 hotfix package
(Graph-x-none.msp, Excel-x-none.msp): August 31, 2010


behoben worden sein.

Dieses Hotfixpaket ist im kumulativen Update für
Office 2010 von August 2010
enthalten und steht
ebenfalls im SP1 für Office 2010 zur Verfügung.

 

Bitte beachten Sie

Stellen Sie bitte nach Installation des 
Hotfixpakets (bzw. Updates, SP1) sicher,
dass sich in den von diesem Bug betroffenen
Arbeitsmappen die Ergebnisse dieser Funktionen
tatsächlich aktualisiert haben:

Drücken Sie hierzu in der entsprechenden
Arbeitsmappe die Tastenkombination Strg+Umschalt+F9
und speichern Sie diese anschließend ab.

Das Hotfixpaket bzw. das Update und das erneute
Abspeichern der Mappe allein führen offenbar
nicht zu einer Aktualisierung der Ergebnisse.

 

Kurzbeschreibung

In Excel 2010 liegt offenbar ein Bug in den Excel-Funktionen SUMMEWENN und MITTELWERTWENN vor, der dann auftritt, wenn bei diesen Funktionen der Zellbereich eines Tabellenblattes für das Argument Bereich und der gleiche Zellbereich eines anderen Tabellenblatts derselben Arbeitsmappe für das Argument Summe_Bereich bzw. Mittelwert_Bereich verwendet wird. Dabei ist es unerheblich, ob der Zellbereich ein Spalten- oder Zeilenvektor oder eine beliebige Matrix ist. Wird bei der Excel-Funktion SUMMEWENNS (bzw. MITTELWERTWENNS) nur ein Kriterium herangezogen und ist der Zellbereich eines Tabellenblatts für das  Argument Kriterien_Bereich1 mit dem Zellbereich eines anderen Tabellenblatts für das Argument Summe_Bereich (bzw. Mittelwert_Bereich) identisch, so kommt hier ebenfalls der Excel-Bug zum Tragen.

Ist in einem solchen Fall das Suchkriterium eine Zahl, so berechnen die Excel-Funktionen SUMMEWENN(S) (bzw. MITTELWERTWENN(S)) die Summe (bzw. den Mittelwert) nicht anhand der Zellen des Arguments Summe_Bereich (bzw. Mittelwert_Bereich), sondern anhand der Zellen des Arguments Bereich bzw. Kriterien_Bereich1, die dem Suchkriterium entsprechen. Liegt demgegenüber als Suchkriterium ein Text vor, so liefern die Excel-Funktionen SUMMEWENN und SUMMEWENNS den Wert null, die Excel-Funktionen MITTELWERTWENN und MITTELWERTWENNS den Fehlerwert #DIV/0!.[1]

 

Syntax der Excel-Funktionen

Die Syntax der Excel-Funktionen lautet:

SUMMEWENN(Bereich;Suchkriterien;[Summe_Bereich])

Addiert die Zellen in einem Bereich, die den angegebenen Kriterien entsprechen.

SUMMEWENNS(Summe_Bereich;Kriterien_Bereich1; 
Kriterien1;[Kriterien_Bereich2;Kriterien2]; ...)

Addiert die Zellen in einem Bereich, die mehreren Kriterien entsprechen.

MITTELWERTWENN(Bereich;Kriterium;[Mittelwert_Bereich])

Gibt den Durchschnittswert (arithmetisches Mittel) für alle Zellen in einem Bereich zurück, die einem angegebenen Kriterium entsprechen.

MITTELWERTWENNS(Mittelwert_Bereich;Kriterien_Bereich1;
Kriterien1;[Kriterien_Bereich2;Kriterien2]; ...)

Gibt den Durchschnittswert (arithmetisches Mittel) aller Zellen zurück, die mehreren Kriterien entsprechen.

Beachten Sie bitte, dass die Reihenfolge der Argumente bei den Excel-Funktionen SUMMEWENN (bzw. MITTELWERTWENN) und SUMMEWENNS (bzw. MITTELWERTWENNS) verschieden ist. Das Argument Summe_Bereich (bzw. Mittelwert_Bereich) ist in SUMMEWENNS (bzw. MITTELWERTWENNS) das erste Argument, während es in SUMMEWENN (bzw. MITTELWERTWENN) das dritte Argument ist. Ferner sind optionale Argumente durch eckige Klammern gekennzeichnet.

 

Beispiel

Im nachstehenden Beispiel soll der Excel-Bug für die vier genannten Excel-Funktionen anhand eines Spaltenvektors und einem Suchkriterium dargestellt werden. Dabei entsprechen die Zellen A2:A8 der Tabelle1 (linke Hälfte der Abbildung 1) dem Bereich, der summiert bzw. für den der Mittelwert berechnet werden soll (Argument Summe_Bereich bzw. Mittelwert_Bereich). Die Zellen A2:A8 der Tabelle2 derselben Arbeitsmappe (rechte Hälfte der Abbildung 1) werden für das Argument Bereich bzw. Kriterien_Bereich1 und die Zelle D1 der Tabelle2 als Suchkriterium verwendet. 

Formeln in Tabelle2:
D3: =SUMMEWENN(Tabelle2!A2:A8;Tabelle2!D1;Tabelle1!A2:A8)
D4: =SUMMEWENNS(Tabelle1!A2:A8;Tabelle2!A2:A8;Tabelle2!D1)
D5: =MITTELWERTWENN(Tabelle2!A2:A8;Tabelle2!D1;Tabelle1!A2:A8)
D6: =MITTELWERTWENNS(Tabelle1!A2:A8;Tabelle2!A2:A8;Tabelle2!D1)

Abbildung 1: Bug in SUMMEWENN(S) und MITTELWERTWENN(S) - Suchkriterium Zahl.

In Abbildung 1 ist das Suchkriterium eine Zahl (Tabelle2!D1: 1). Die Excel-Funktionen SUMMEWENN(S) (bzw. MITTELWERTWENN(S))  berechnen  für das Beispiel anscheinend die Summe (bzw. MITTELWERT) der Zellen des Arguments Bereich bzw. Kriterien_Bereich1, die dem Suchkriterium entsprechen,

Demgegenüber ist in Abbildung 2 das Suchkriterium ein Text (Tabelle2!D1: a). Die Excel-Funktionen SUMMEWENN und SUMMEWENNS liefern als Ergebnis den Wert null, die Excel-Funktionen MITTELWERTWENN und MITTELWERTWENNS den Fehlerwert #DIV/0!.


Formeln in Tabelle2:
D3: =SUMMEWENN(Tabelle2!A2:A8;Tabelle2!D1;Tabelle1!A2:A8)
D4: =SUMMEWENNS(Tabelle1!A2:A8;Tabelle2!A2:A8;Tabelle2!D1)
D5: =MITTELWERTWENN(Tabelle2!A2:A8;Tabelle2!D1;Tabelle1!A2:A8)
D6: =MITTELWERTWENNS(Tabelle1!A2:A8;Tabelle2!A2:A8;Tabelle2!D1)

Abbildung 2: Bug in SUMMEWENN(S) und MITTELWERTWENN(S) - Suchkriterium Text.

Unabhängig davon, ob es sich bei dem Suchkriterium um eine Zahl oder einen Text handelt, sollten sich bei diesem Beispiel für die Excel-Funktionen SUMMEWENN und SUMMEWENNS der Wert 1.600 sowie für die Excel-Funktionen MITTELWERTWENN und MITTELWERTWENNS der Wert 400 ergeben.

 

Workaround

Der betrachtete Excel-Bug tritt lediglich dann auf, wenn der Zellbereich eines Tabellenblatts für das Argument Bereich bzw. Kriterien_Bereich1 mit dem Zellbereich eines anderen Tabellenblatts für das Argument Summe_Bereich bzw. Mittelwert_Bereich identisch ist. Naheliegend ist folglich eine Zeile oder Spalte einzufügen oder einen der beiden Zellbereiche auszuschneiden und an anderer Stelle wieder einzufügen, so dass sich die beiden Zellbereiche voneinander unterscheiden. So kann für das betrachtete Beispiel entweder eine Spalte vor die Spalte A in Tabelle1 eingefügt werden oder der Zellbereich Tabelle1!A1:A8 ausgeschnitten und in Zelle Tabelle1!B1 eingefügt werden. Die Zellbezüge für das Argument Bereich bzw. Kriterien_Bereich1 aktualisieren sich daraufhin bei den vier Excel-Funktionen, welche sodann die korrekten Ergebnisse liefern (vgl. Abbildung 3). Machen Sie diese Aktion rückgängig (Strg+Z), so liegt der Excel-Bug wieder vor und Sie erhalten erneut falsche Ergebnisse.

Formeln in Tabelle2:
D3: =SUMMEWENN(Tabelle2!A2:A8;Tabelle2!D1;Tabelle1!B2:B8)
D4: =SUMMEWENNS(Tabelle1!B2:B8;Tabelle2!A2:A8;Tabelle2!D1)
D5: =MITTELWERTWENN(Tabelle2!A2:A8;Tabelle2!D1;Tabelle1!B2:B8)
D6: =MITTELWERTWENNS(Tabelle1!B2:B8;Tabelle2!A2:A8;Tabelle2!D1)

Abbildung 3: Workaround - Unterschiedliche Zellbereiche.

Soll keiner der beiden Zellbereiche verschoben werden, kann anstelle der Excel-Funktion SUMMEWENN (bzw. MITTELWERTWENN) auf die Excel-Funktion SUMMEWENNS (bzw. MITTELWERTWENNS) zurückgegriffen werden. Zwar liefern diese bei den betrachteten Zellbereichen und einem Kriterium nicht das richtige Ergebnis, werden jedoch mehrere Kriterien verwendet, so sind diese Excel-Funktionen von diesem Bug anscheinend nicht mehr betroffen. Dies ist selbst dann der Fall, wenn ein Kriterium für denselben Kriterienbereich wiederholt verwendet wird. Es kann also wie in Abbildung 4 geschrieben werden:

Formeln in Tabelle2:
D4: =SUMMEWENNS(Tabelle1!A2:A8;Tabelle2!A2:A8;Tabelle2!D1;Tabelle2!A2:A8;Tabelle2!D1)
D6: =MITTELWERTWENNS(Tabelle1!A2:A8;Tabelle2!A2:A8;Tabelle2!D1;Tabelle2!A2:A8;Tabelle2!D1)

Abbildung 4: Workaround - SUMMEWENNS und MITTELWERTWENNS.

Weitere Formellösungen sind natürlich denkbar bspw. mittels der Excel-Funktion SUMMENPRODUKT oder anhand von Array-Formeln mit SUMME bzw. MITTELWERT und einer entsprechenden WENN-Bedingung.

 

Resümee

Der Bug ist lediglich in Excel 2010 und bei tabellenblattübergreifenden Arbeiten mit identischen Zellbereichen bei den behandelten Excel-Funktionen zu finden. Er ist ferner unabhängig vom verwendeten Dateiformat. Identifizierbar ist dieser Bug vornehmlich dann, wenn als Suchkriterium ein Text verwendet wird. Dient demgegenüber als Suchkriterium eine Zahl, kann es mitunter schwer sein einen Fehler auszumachen. Da die Excel-Funktion SUMMEWENN bereits in Versionen vor Excel 2007 zur Verfügung steht als auch in der Praxis wesentlich populärer ist als die erst mit Excel 2007 eingeführten Excel-Funktionen SUMMEWENNS, MITTELWERTWENN und MITTELWERTWENNS, wird die Wahrscheinlichkeit, diesen Bug bei der Excel-Funktion SUMMEWENN anzutreffen, vermutlich höher sein als bei den anderen drei Funktionen.   

 

[1] Andreas Entenmann (Excel MVP und zertifizierter SAP Trainer und Berater) hat diesen Excel-Bug bereits im Artikel Summewenn Bug in 2010? thematisiert. Weitere Diskussionen finden sich auf Microsoft Answers Deutschland im Forum 'Microsoft Excel' Artikel SUMMEWENN_Funktion Office 2010 sowie auf Microsoft Office United States im Forum 'Excel IT Pro Discussions' Artikel BUG in Excel 2010 SUMIF & SUMIFS functions [EDIT: also AVERAGEIF & -IFS].

 

Haben Sie Fragen oder Anregungen zu diesem Artikel?

Dann senden Sie einfach eine Nachricht an:

E-Mail:

 

Lesen Sie auch:
___________________________________________________________________

Eigenartiges Blinken der Fenstersymbole - Bug in Excel 2010?